Mazda World Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have a 1992 Mazda 929. I changed the thermostat in it and still do not have heat. The gauge reads between cold and hot, the heater hose is warm but still no heat. I have learned that there is a heater control valve somewhere in the system that may be the problem. Can anyone tell me where it is located? Do you have any other suggestions on this problem? It is very difficult to drive in Michigan this time of year without heat to defrost your windows, heat the car, etc.

Thanks,
CO2Man :grr:
 

·
Registered
Joined
·
330 Posts
Did you check both heater hoses? Inlet and outlet. Warm dont sound good, should be hot.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
I can look up where the valve is located and if there is such a thing. Where in Michigan are you located?[/b]
I am located in Livonia, Michigan. Yes, if you could provide me with location info., it would be greatly appreciated.
 

·
Registered
Joined
·
34 Posts
I have a 1992 Mazda 929. I changed the thermostat in it and still do not have heat. The gauge reads between cold and hot, the heater hose is warm but still no heat. I have learned that there is a heater control valve somewhere in the system that may be the problem. Can anyone tell me where it is located? Do you have any other suggestions on this problem? It is very difficult to drive in Michigan this time of year without heat to defrost your windows, heat the car, etc.

Thanks,
CO2Man :grr:
If you end up needing that part the dealers say it's discontinued but I got mine from this website https://www.mazdapartsprime.com/oem/mazda-control_htr-hg3061190d.html?Make=Mazda&Model=929&Year=1992&Submodel=&Filter=(Base,6+Cyl+3.0+L+GAS) It's says it's discontinued also but if you ask them to check VPI for it they can get it for you. they only have one left but just wanted to let you know O.E. parts are always best.
 
1 - 8 of 8 Posts
Top