Mazda World Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
547 Posts
Discussion Starter #1
Just yesterday my AC started blowing warm air and I let 95 Millenia 2.5L AC run while driving and in 20 minutes into my drive started up blowing cold again. Then I arrived at my destination, turn off the car and came back to the car after a hour and started up it up with warm blowing again. Continued driving it back to my home - 25 minutes in warm mode.

What do you think is wrong with it?

I changed out the AC/heat control unit already to a brand new OEM unit!
 

·
Registered
Joined
·
1,409 Posts
it could be this here critter:
97 Mazda Millenia Blend Door Actuator GA601TAO1C 7c | eBay

but there are different versions of them. i have a spare that the last digits is -1E. i cant find a good pic of where it is on the blower assembly, there used to be several on ebay. this actuator moves the blende door that controls heat and cold. since the car is climate control, a/c and heat are always on, and this actuator controls how much heat is mixed with cold. the door is moving a lot, and i think this is the most common failure. i found a post on someone who changed this out, but on the other group. he went in thru the radio opening, but it can clearly be seen if you remove the glovebox door. i have never installed one, and it looks to be a bit tricky, because there is a bellcrank on the back that has to attach to the blende door, and the person who installed it had problems holding it in place while the screws were first put back. i think eventually it will fail in the position that will not allow cold air. the japanese follow the germans a lot, and it europe, the default position is defrost mode. if i were to try to install this, i would first try removing the glovebox, and going in that way. a word of caution, a used one might be in worse condition than what you have
 

·
Registered
Joined
·
547 Posts
Discussion Starter #3 (Edited)

·
Registered
Joined
·
1,409 Posts
yup, that's it. i was lucky, i got a whole blower assy with the evaporator and the actuators for like 60 bucks. if you turn the ign on, not start, then turn on the a/c and go from hot to cold, you should hear it. if you remove the glovebox, you will see it, and it should move the door. i am only guessing it is the actuator, but they do mess up a lot.
 

·
Registered
Joined
·
547 Posts
Discussion Starter #6
hi mazda-fla and kennin,

It works again! Cold air!

But I guess I need to take either the glove box or radio unit out to see what exactly my blend actuator actually looks like so I can replace it. I kind of confuse as to which unit is the right one since posting have the same " BLEND DOOR ACTUATOR " as the description but show no front plug in why others have a wire on the side for to plug in. Not sure what the back of the blade looks like either; duel long with two knobs on it or one short knob at the end. So if anyone know which one goes with a 95 Mazda Millenia; please let me know! Otherwise, I going to have figure out which is the easiest to pulling out - radio or glove box!
 

·
Registered
Joined
·
1,409 Posts
99 millenia s blowing hot air, freon ok, lines are cold - Page 2 - Mazda Forum - Mazda Enthusiast Forums

dunno if this link will work if you are not registered, but it is from the other mazda forum. i think removing the glovebox gives better access to the actuator. our 2 cars have the same actuator, there is NO pigtail, there is a multipin connector on the front of the actuator. i have a really good pic of the actuator, but i dont know how to post pics. the glovebox is easy to pull. then you can try tapping on the actuator. since i got a whole hvac box, i could see how the doors move
 

·
Registered
Joined
·
547 Posts
Discussion Starter #8 (Edited)
Thank Kennin for IDing the blend actuator. I am going shop for this part as backup in case the AC acts up again. Not going to go through the trouble of removing the glove box. No reason for that since I now know the part I am after!


Sent from AutoGuide.com Free App
 
1 - 8 of 8 Posts
Top