Mazda World Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
For those who need to know.
Code 44 = 4 flashes, a pause and 4 more flashes refers to the left hand side or drivers side, side impact sensor located at the center pillar just below the lower mounting bolt for the seat belt and behind the plastic trim.
Code 45 = 4 flashes, a pause and 5 more flashes refers to the right hand side or passenger side, side impact sensor located at the center pillar just below the lower mounting bolt for the seat belt and behind the plastic trim.
In both cases, it is a communication error.

The Fix.
First, remove the front and rear door threshold (Plastic trim). Next, remove the center pillar lower trim piece. You should not need to remove the upper piece but you will have to wrestle with the lower piece to remove and re-install.
Just below the seat belt mounting bolt you will find the sensor. I disconnected the battery, both terminals, and waited about 30 Minutes before removing the sensors. Disconnect the harness, and then remove the 2 mounting bolts. Inspect the sensor body for any damage. If it’s cracked, you should probably replace it. In my case, the copper and silver mounting wrings were very dirty. I cleaned them with brake parts cleaner, sand paper and a wire brush until they were shiny. I soaked the bolts in the brake parts cleaner and then dried them off. I sprayed all the contact points with Deoxit electronics cleaner, let them dry and then re-install the parts. Worked like a charm, no more error codes! I would shy away from using WD40. I think the oil will attract too much dirt and grime.

Good Luck:smile:
 

·
Registered
Joined
·
53 Posts
Discussion Starter #2
I was wrong with this fix




Turns out, a few days after I “Fixed” the air bags, the light started flashing again. This time, before doing anything else, I tested the charging system (should have done that first) and found that the alternator was weak. So guess what the fix was. You guessed it, had to change the Alternator. (See my other post)


No more light and everything works and feels like new!
 
1 - 2 of 2 Posts
Top