Mazda World Forum banner
1 - 4 of 4 Posts

·
Registered
2014 Mazda CX-5 Sport Touring Front-wheel
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
I have a 2014 Mazda CX-5 with 91K miles on it. It developed a problem recently where about 8-9 dashboard warning lights are on. I replaced the battery and that didn't help.

I took it to a local auto service dealer (not Mazda authorized) and they said that the ABS module has no power and communicating. As a result the other things are failing too. The speedometer remains stuck at 0. The car doesn't turn off easily. I need to told the on-off button for 3-4 seconds and then accessories remain on. I have to again keep the button held for another 3-4 seconds to fully turn off the car.

I have a simple OBDII scanner and read the codes. There were two pending - U121 and U122 - "Lost Communication With Anti-Lock Brake System (ABS) Control Module". I reset that and it came back on a bit later. I doubt that is the root cause of all other lights being lit. I think (with no real basis) that the voltage of the system is low or grounding fault or some fuse issue that is cause the ABS to lose a connection with the main control module?

Any ideas if I can debug this further myself rather than bringing this to Mazda service center? Could it be something simpler? Anything that I can do to confirm before paying $400 to Mazda for just diagnosis (their quote over the phone)?
 

·
Registered
2014 Mazda CX-5 Sport Touring Front-wheel
Joined
·
5 Posts
Discussion Starter · #3 ·
You may buy an obd reader and use forscan to look for the fault codes
Thanks. Edited the post. Yes, I have had a scanner for a long time and finally got to use it. The code was U0121. ABS lost connection with the module. Not sure if it will lead to all other problems though.
 
1 - 4 of 4 Posts
Top