Mazda World Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

I’m writing you today to implore your help on an issue which has been plaguing me for the past two weeks. I’ve been searching the web high and low for an answer and trying everything I can think of, but I’m very much stumped.

My car is a 2005 Mazda3 S hatchback.

One morning as I was leaving for work, I sat in my car like usual, but when I turned the key in the ignition the car cranked, but didn’t start. I tried this a few more times before giving up and rode my motorcycle to work.

During my troubleshooting I noticed the fuel pump wasn’t turning on when I turned the key. I had someone turn the key as I stood by the tank listening. Nothing. I removed the seat and opened the access hatch to be sure. I placed my hand on the fuel line this time to see if I could feel the pump working and listened again. Again nothing. Just to be sure, I disconnected the hose which feeds into the fuel rail and placed it into a jar to see if any gasoline was being pumped. No gas.

So, I ordered a new fuel pump and thought my problems were solved. In the process of troubleshooting I also tested the wiring harness while someone turned the key and measured 12 volts at the wiring harness.

After installing the new pump and connecting everything back up I tried starting the car again. Still turned over, but didn’t start, I also noticed that this new fuel pump wasn’t starting either. Great…

I go grab my old pump and connect the positive and negative wires to jumpers to check and see if it’s working, and it starts right up. So, it’s not the pump… I reinstall my old pump, try starting my car just to check, and it starts right up. I feel confused, but extremely relieved. I turn it off and on a couple more times to be sure, and put everything back together again.

Once the car is all in one piece again, I decide to drive it around a little to make sure everything’s still alright. When I go to start the car, nothing. I listen for the fuel pump, again silence…

I've tested the relay for continuity, just to be sure and it checks out. Same with the fuse. I’m getting 12 volts at the harness, and when I connect 12 volts to the pump outside of the car, everything works fine. I tested the ground at the fuel pump wiring harness, and the ground is good.

I’ve run out of ideas and my car has been out of service for over a week now. Has anyone ever experienced anything like this in their car? Anyone with more experience care to help a poor tortured soul? I don’t think I’ve ever been this stumped on a car problem. Am I missing something?

Recap:

Fuel pump works when connected to 12-volt power supply after being removed from the tank

12 Volts measured at fuel pump wiring harness when key is turned to “ON”, drops to 10.5 volts when cranking

No resistance at fuel pump wiring harness ground, the ground is good

Relay switches and shows continuity, swapped with a different relay to be sure, but no luck

Fuse is intact

Help!
 

·
Registered
Joined
·
4 Posts
You may have a wiring problem. Replace the harness. Even though it checks out with the volt meter, it may not be making good contact with the pump harness.
 
1 - 2 of 2 Posts
Top