Mazda World Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 02 Mazda 626 V6 and have 104,000 miles. on it. Recently on three different occasions after driving the car a total of approx. 15 to 25 miles; after I stop and try to restart, it continually starts and dies. After it sits for a few hours, it starts and drives fine. Recently though car is having more issues with starting.

First trip to the dealer: Couldn't find a problem. The problem didn't show up for them. Second trip: They said it was the computer going out, they couldn't come up with anything else to say i believe. I've now had it in three different shops and no one can tell me exactly what is going wrong. There are no codes that show up but no one not even Mazda dealership can tell me what is going wrong. Car is sitting in my driveway not wanting to start. I need answers if anyone can help please let me know. Thanks
 

·
Registered
Joined
·
31 Posts
You could always do some little inexpensive things on your own for your piece of mind. I personally would replace the MAF sensor, clean the throttle-body butterfly and clean the injectors and change the fuel filter to see if that helps... and if it doesn't you can rule those things out. If the problem was the starter or alternator they definitely would've caught it by now. I know a tech at the shop I worked at for a while couldn't get this truck he was working on started. It turned out to be a messed up MAF sensor throwing off the a/f ratio, but he only found out after darn near tearing down the whole motor.
 

·
Registered
Joined
·
2 Posts
Did you ever get this sorted? I have a similar problem on a 99 626. Always starts first time but 50% of the time it'll them cleanly cut out after 5 seconds. Does this twice then doesn't start again until you try hours later, and even then it's a 50/50 chance. Once it passes that 5 seconds it works great and always sounds clean.
 

·
Registered
Joined
·
2 Posts
Check your fuel pressure as well as the resistance within the coil pack.
Thanks Bolton. As an update - I noticed that the times when it does start, the immobiliser icon flashes up "car with a key in". The times when it will cut out, that doesn't flash up. So seems like it's an immobiliser issue. The behavior when there's an immob issue is for it to start 3 times but cut out 5 seconds into each, then refuse to start. This is exactly what's happening on mine. We did have replacement keys cut after losing them a couple of years back and they've been fine till now, but maybe some intermittent issue with the transponder in the keys. Haven't worked out how to fix it yet but at least I know what to look into now.
 

·
Registered
Joined
·
1 Posts
I have a 02 Mazda 626 V6 and have 104,000 miles. on it. Recently on three different occasions after driving the car a total of approx. 15 to 25 miles; after I stop and try to restart, it continually starts and dies. After it sits for a few hours, it starts and drives fine. Recently though car is having more issues with starting.

First trip to the dealer: Couldn't find a problem. The problem didn't show up for them. Second trip: They said it was the computer going out, they couldn't come up with anything else to say i believe. I've now had it in three different shops and no one can tell me exactly what is going wrong. There are no codes that show up but no one not even Mazda dealership can tell me what is going wrong. Car is sitting in my driveway not wanting to start. I need answers if anyone can help please let me know. Thanks
Possible with transponder or key, or ignition switch?
 
1 - 7 of 7 Posts
Top