Mazda World Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We've already had the tranny replaced after 64K and now we have another unusual problem. When you put the MPV in park - the shifter "locks up" and can not be moved. There is a plastic knockout on the top of the steering column housing with a plastic lever underneath that "unlocks" the transmission shifter. The electronic gear display (P, R, D, 1, 2) no longer highlights the gear you are in.

I'm not thrilled with the idea of giving Mazda anymore money to keep this dog running. Has anyone had this problem and can recommend a fix?
 

·
Registered
Joined
·
3 Posts
We've already had the tranny replaced after 64K and now we have another unusual problem. When you put the MPV in park - the shifter "locks up" and can not be moved. There is a plastic knockout on the top of the steering column housing with a plastic lever underneath that "unlocks" the transmission shifter. The electronic gear display (P, R, D, 1, 2) no longer highlights the gear you are in.

I'm not thrilled with the idea of giving Mazda anymore money to keep this dog running. Has anyone had this problem and can recommend a fix?
[/b]
Just got the same problem. Did you ever find a fix?

Andy
 

·
Registered
Joined
·
3 Posts
Thanks. figured it was something like that--speedometer and radio out too, but local mechanic checked all fuses--fuses good, and power to fuses. Brake light works, too. He thought it was the antitheft system, but antitheft company (and others) say no--wouldn't run at all if it were that. By the way, this one is a 2000. I'll let you know what I find out.
 

·
Registered
Joined
·
3 Posts
The van is fixed. I got the details indirectly, but as nearly as I can understand from what my wife relates it to me, it was the solenoid that releases the shifter when you push on the brake pedal, or some circuit that operates that solenoid, that got fried. She also said he reset the computer. Apparently something got scrambled in the computer which caused the other symptoms (speedometer out, shift indicator out, performance problems) I'm guessing he was referring to the computer in the dashboard, not the main computer--the local shade tree guy scanned it last week and didn't find any relevant codes.

But this is the interesting part: shop says the cause was a KNOWN ISSUE: the CD player builds up static, and the discharge of the static can burn out various components. He said not to play any more CDs until they get the CD player case replaced with a plastic one--apparently Mazda is responsible for that.

Andy
 

·
Registered
Joined
·
1 Posts
Neutral Safety Switch

I just repair my MPV and the problem was the Neutral Safety Swicth. Cost me $100. First check the Car Lighter fuse and then the NSS.
 

Attachments

·
Registered
Joined
·
1 Posts
I had a problem with dash lights, dash gauges not working plus gear selector locking in park. The fuse that controls the lights and gauges kept blowing?? Disconnected the battery for a couple of hours, replaced the fuse and bingo everything is working again. I have no idea why? could be a computer issue or a sensor or solenoid shorting. Got me stumped. This is on a 2003 MPV
 
1 - 7 of 7 Posts
Top