Mazda World Forum banner

541 - 560 of 564 Posts

·
Registered
Joined
·
34 Posts
they told me the headlight set was over 500.00 new. it had like over 130k miles and they would NOT fix it and gave me like 1,300.00. thats state farms for you.. ;) I kid you not, they didnt wanna fix my precious car i loved and i was paying over 600.00 every six months for it.


i just love it when you pay insurance money and they dont wanna shell out money to fix your car.... so what are we exactly paying them for? why is this the LAW and they arent following through on what they are suppose to do after an accident let alone not my fault accident?
 

·
Registered
Joined
·
5 Posts
im new to this and dont really know where to put this at but this kinda seemed good, well for some reason ive recently developed a leak somewhere and water keeps getting on my back passenger floorboard and soaked which stinks sitting inna hot car, my tcs on and off light stay on and when i push the button it does nothing, i can wiggle both of my front wheels slightly left right and down ha and as everybody elses the tilt steering wheel is broke lol i got it right where i want it and leave it somebody please help!!!!! and its a 01 millenia 2.3
 

·
Registered
Joined
·
60 Posts
High Kms on Mazda Eunos 800M

I may have one of the oldest dated Millenia here in Australia Mazda Eunos 800M year 1994

Year: 1994 S (released in Australia as the Eunos 800M)
Mileage: 460,000 km or 287500 miles
Major problems had:
1. Replacement Supercharger
2. 3 ignition coils
That's all folks:rolleyes:
 

·
Registered
Joined
·
58 Posts
Worlds most reliable, unreliable car

2002 Millenia S owned since 4/10/12 w/109,000 miles

Currently 117,000 miles

Replaced CV axles
Replaced thermostat
Complete brake overhaul--wallet still recovering
Worthless auto trans going out
S/C going out
Struts going out
Alternator going out
Bad front wheel bearings
Fubar vac line T's
Rims wont stay balanced more than a week due to severe salt corrosion
Rear wheel wells completely rotted out

This may be the worlds most reliable, unreliable car but I still love it. The only thing I hate about the car is the useless auto trans. I'm seriously considering about converting to a manual.
 

·
Registered
Joined
·
8 Posts
I just bought my 2nd Milly this year. I used to have a 95 wasn't the S. That one blew up after 6 months it overheated and I was 18 and cared little about anything but opening the moon roof, leaning my seat too far back, blaring my music and speeding ( wait, I still do that ) anyway. This year I found a 2000 S ME with only 104k for 1000 bucks, it had a broke SCer and the guy wasn't interested in spending 2000 at best. I was, So now I have 3000 invested .. and other than the SCer replacement, the rims ( I'm told they are known for this ) are busting the beads of my tires, ( sometimes they hold air sometimes they don't , I'm having the rims filed down, ( not expensive ) and my temperature controls don't work, I can turn both defrosts on and off and adjust temperature, all the other buttons do nothing. No other issues.
 

Attachments

·
Registered
Joined
·
8 Posts
2002 Millenia S owned since 4/10/12 w/109,000 miles

Currently 117,000 miles

Replaced CV axles
Replaced thermostat
Complete brake overhaul--wallet still recovering
Worthless auto trans going out
S/C going out
Struts going out
Alternator going out
Bad front wheel bearings
Fubar vac line T's
Rims wont stay balanced more than a week due to severe salt corrosion
Rear wheel wells completely rotted out

This may be the worlds most reliable, unreliable car but I still love it. The only thing I hate about the car is the useless auto trans. I'm seriously considering about converting to a manual.

Auto trans is the ONLY thing I don't like about my car, if you successfully change yours, would you mind doing it on mine ? :)
 

·
Registered
Joined
·
58 Posts
Auto trans is the ONLY thing I don't like about my car, if you successfully change yours, would you mind doing it on mine ? :)
My biggest complaint about the LJ4A-EL trans is that it restricts a lot of power and I'm sure you can fit another trans in between the gear ratios (typical 4-speed auto). I could talk straight into next week about how much I hate automatics. According to numerous sources Mazda did offer a manual trans for the Millenia, but only for European 2.0 and 2.5 V6's. The KL 5 speed should bolt up to the KJ, thats the easy part, but you would have to either have to track down manual components or fabricate your own parts, then you have to trick the computer to think that it still has a automatic, etc. Its a lot of work, someone here in the MSP area did successfully (for the most part) swap in a manual trans on a older Millenia S. The video should still be on Youtube, but a year or two ago I could swear I saw it for sale on Craigslist.
 

·
Registered
Joined
·
8 Posts
My biggest complaint about the LJ4A-EL trans is that it restricts a lot of power and I'm sure you can fit another trans in between the gear ratios (typical 4-speed auto). I could talk straight into next week about how much I hate automatics. According to numerous sources Mazda did offer a manual trans for the Millenia, but only for European 2.0 and 2.5 V6's. The KL 5 speed should bolt up to the KJ, thats the easy part, but you would have to either have to track down manual components or fabricate your own parts, then you have to trick the computer to think that it still has a automatic, etc. Its a lot of work, someone here in the MSP area did successfully (for the most part) swap in a manual trans on a older Millenia S. The video should still be on Youtube, but a year or two ago I could swear I saw it for sale on Craigslist.

Yup, sounds like ill be driving the automatic as the factory built it till the wheels fall off, When I have the spare cash, Ill just buy a 5 speed somethin else. I AM going to do a cat back, get a performance air filter ( not try and customize an intake,) and get a performance chip. then tint the windows, install dvd in dash and maybe lower the car a few inches.
 

·
Registered
Joined
·
9 Posts
02 2.5 - 150,000

Torn axle boot
Timing belt never changed
Oil leak from cam and front crank seals
Struts front and rear worn with rear mounts knocking
Transmission solenoids "sticking"
Tires worn
Front converter faulty
Lifter tick
 

·
Registered
Joined
·
5 Posts
I have 99s
Milage: 22x,xxx
Got it 1year and 1 month
Put 80,000 since I had it😁
Problems;
-ignition coil
-cv axcel
- tie rod ends ball joints bearing and upper control arm.( both sides)
-TCS sensor (which is still on) any ideas?
--Fog lights (still don't turn on and I swapped the switch and relay already)
-supercharger ( rebuilt and replaced)
Other than this it runs like a champ beat a scion tc last night pretty proud of my girl ❤


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
10 Posts
I have a 2000 Xedos 9 2.3 (I'm in the U.K.) I have had it for about 10 years. It has 140K miles on the clock. No real problems. I had a transmission fluid leak from a fractured metal pipe just where the flexible pipe joins down at the bottom of the radiator, fixed it before the gearbox suffered. Just had a coil pack go faulty. The problem here is it is a very rare car in the U.K. so practically no second hand spares to be found. Just remembered it leaked water into the spare tyre well, turned out to be a body seam not perfectly sealed down by the rear light cluster. I had to strip out the rear seats and climb in with a torch whilst my wife hosed the car with water.
 

·
Registered
Joined
·
7 Posts
2002 Milly 'S' bought it this summer for my teenage son with 60k miles on it, am in the middle of timing belt job, waiting on o-rings for water outlet. Had a vibration while driving, turned out to be defective driver-side driveshaft that previous owner had just replaced, bad aftermarket part. Otherwise ok so far.
 

·
Registered
Joined
·
31 Posts
I have a 2000 Xedos 9 2.3 (I'm in the U.K.) I have had it for about 10 years. It has 140K miles on the clock. No real problems. I had a transmission fluid leak from a fractured metal pipe just where the flexible pipe joins down at the bottom of the radiator, fixed it before the gearbox suffered. Just had a coil pack go faulty. The problem here is it is a very rare car in the U.K. so practically no second hand spares to be found. Just remembered it leaked water into the spare tyre well, turned out to be a body seam not perfectly sealed down by the rear light cluster. I had to strip out the rear seats and climb in with a torch whilst my wife hosed the car with water.
I'm a fellow Uk'er matey! Keep her going!
 

·
Registered
Joined
·
2 Posts
I have 99s
Milage: 22x,xxx
Got it 1year and 1 month
Put 80,000 since I had it😁
Problems;
-ignition coil
-cv axcel
- tie rod ends ball joints bearing and upper control arm.( both sides)
-TCS sensor (which is still on) any ideas?
--Fog lights (still don't turn on and I swapped the switch and relay already)
-supercharger ( rebuilt and replaced)
Other than this it runs like a champ beat a scion tc last night pretty proud of my girl ❤


Sent from AutoGuide.com Free App
Hi Chris!

Looks like you're putting on about 7500 miles every 2 1/2 months. You got a ton of mileage on that car. That's impressive!

Do you change oil every 7500 with synthetic oil or do you use regular motor oil every 3000 miles or approximately every 4-5 weeks?

Do you add sea foam motor oil treatment in you tank to help keep your injectors and upper cylinder clean of carbon, and do you add sea foam to your crankcase a few days before you do an oil change? If you don't you might consider doing this to keep all oil passages clear of debris out of your Lysholm compressor, since you have already had to replace the compressor.

I have read on forum where guy rebuilt the compressor or the S/C, and the crud he found in the oil return port, which causes oil to accumulate in the compressor compartment and oil to be burnt during ignition and I immediately thought of using the sea foam prior to oil changes and how that would help reduce or eliminate these blockage problems.

I have also read that this engine should only use regular unleaded gasoline and using high quality synthetic oil in helping extend the life of this engine, as well as the Lysholm compressor as it looks or sounds like this may have been done in the past, or it would not have such high mileage, and except for the replacement of the SC/compressor it all sounds good.

I suppose you have a scan tool? If you are getting TCS off lights; on you might want to check you vacuum hose connections to the air bypass solenoids (vent and vacuum) and especially if you are getting P1526/1540 and you're getting them persistently along with an occasional P0170/0173. This is a huge problem.

BTW, the ABV vent solenoid and the ABV vacuum solenoid are located beside the EGR valve, behind the rear bank manifold, and if looking from front of car, and left to right, they are the second one (vent solenoid) and the fourth or last one to the right of that cluster of solenoids.

I have this problem (TCS off light coming on) and my car goes into limp mode which may also trigger a P0725. In the case of my 99 Milly S, I replaced the fuel filter, which was filthy as a pig pen, and also found it filled with dirt, and moisture droplets, and added antifreeze in radiator, and when I did that; it eliminated the TCS light off from coming on for a day. I went from over joyed to depressed. I am convinced I will find the filter plugged again.

I plan on getting a smoke test done on vacuum lines, to see if I have loose or disconnected vacuum hose(s) on the ABV vent/vacuum solenoids, before I make up my mind to replace them. I will also be checking fuel pressure, leakage at air tubes and possible plugged return lines from fuel pressure regulator. I will also use the sea foam additive every fuel fill up hoping to clean up the fuel on this pig and hopefully avoid dropping the fuel tank and having it cleaned. Iam hoping to make this pig into a lean mean running machine.

Lastly, you might to visit this sight and bookmark or favorite it:

milleniatech.net

Well Chris, that's my 3 cents on this subject. Thanks for reading my post and hope it helps you and others.

Good luck with your Milly! Take care
 

·
Registered
Joined
·
15 Posts
mine has 76k on it--driving me nuts-fix the solenoid-now it says abv circuit-love the car but its frustrating- oh yeah cv joint or joints bad--cold air hot heat-new tires-idk what to do with this car!!!
 

·
Registered
Joined
·
2 Posts
I have a 2000 Mazda Millenia. It has 195,000 miles. It started overheating, had the thermostat replaced and a hose replaced. It ran for a week then wouldn't crank up. I had the distributor and cap replaced along with the spark plugs... It crunk but once i cut it off it wouldn't crank again. What could possibly be the issue??
 

·
Registered
Joined
·
5 Posts
2001 Mazda Millenia S
175xxx KMs

Owned for 3-4 years

Problems

Misfiring due to broken ignition coil wire
Vacuum Leak -fixed
CV join -fixed
control arm -fixed
tie rod -fixed
another control arm-fixed
leaking PS cooler line -fixed
Leaking Rack and pinion -fixed
5 more pieces of suspension steering going out
Leaking VCG - fixed
Car will not accelerate well with more than 1/3 throttle
vacuum leak
 
541 - 560 of 564 Posts
Top